Latest Articles

Disable “No Internet Access” notification on Windows Server 2008 (R2).

The “No Internet Access” notification on the network connection icon usually appears when you’re not connected to the Internet or you probably behind a proxy server. However, when you setting up your servers in an isolated environment without Internet access and you want to disable this notification then:

  1. Open the GPMC.msc.
  2. Create or open a GPO which will be applied to your server(s).
  3. Navigate to Computer ConfigurationPoliciesAdministrative TemplatesNetworkNetwork Connections.
  4. Enable the “Do not show the “local access only” network icon” setting.
  5. Close the GPO and GPMC.msc.
  6. Run C:\>gpupdate on the server(s) to apply the new policy.

The “No Internet Access” notification should be disabled now.

Cheers!

– Marek.Z

About Marek (288 Articles)
Marek is an IT professional with 15+ years of experience in the IT industry and is currently working as PSO Senior Consultant SDDC at VMware for the NEMEA region.

8 Comments on Disable “No Internet Access” notification on Windows Server 2008 (R2).

  1. Good timing, thanks! Just today I started looking for a solution to get rid of this message, too! 🙂

  2. By any chance, do you know where that setting is in the registry? I would like to set it via a script, but I’m having a terrible time finding the right key…

    “EnableActiveProbing” seemed promising, in HKLMSystemCurrentControlSetservicesNlasvcParametersInternet…Found one report stating that did it for Vista, but it definitely doesn’t work for W2k8 R2.

  3. I’m getting this issue even while connected to the internet. Any ideas why the system shows disconneccted even though it is online? New 2008 Std R2 virtual configuration.

  4. Dear,

    I would like to inform you that, We have a problem since two days for Internet connectivity in windows Server 2008 DC and clients side Win7.

    The error appear with yellow triangle exclamation mark in Client side and Server side show the Internet access but we not able to browse.

    Kindly help how we resolve this issue. we are using (TMG) proxy Server through Domain Active directory.

    We have been upgrade Server domain from 2003 To 2008 standard 32Bit SP1. Previous it was working Internet smoothly with Windows 2003 server Enterprise and Client side.

    Please give us solution ASAP how we fix this Issue in both side.

    • Hi,

      Did you enable internet browsing for you clients through the TMG server? Simply open port 80 and 443 through an access rule.

      Cheers!

Leave a reply...